aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorptrkrysik <ptrkrysik@gmail.com>2014-08-14 14:56:16 +0200
committerptrkrysik <ptrkrysik@gmail.com>2014-08-14 14:56:16 +0200
commit3543384ad05f07fd22eb71096ccca4e329390c8e (patch)
treeb4fe55b163aeafd07807afe2177277aa2d6fb199 /CMakeLists.txt
parenta07948f032d6aa261a0c90888f5682e433e04faf (diff)
New checks in Cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ce77ab..929fa99 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,6 +85,7 @@ set(GRC_BLOCKS_DIR ${GR_PKG_DATA_DIR}/grc/blocks)
########################################################################
find_package(GnuradioRuntime)
find_package(CppUnit)
+find_package(Doxygen)
# To run a more advanced search for GNU Radio and it's components and
# versions, use the following. Add any components required to the list
@@ -102,6 +103,15 @@ if(NOT CPPUNIT_FOUND)
endif()
########################################################################
+# Setup doxygen option
+########################################################################
+if(DOXYGEN_FOUND)
+ option(ENABLE_DOXYGEN "Build docs using Doxygen" ON)
+else(DOXYGEN_FOUND)
+ option(ENABLE_DOXYGEN "Build docs using Doxygen" OFF)
+endif(DOXYGEN_FOUND)
+
+########################################################################
# Setup the include and linker paths
########################################################################
include_directories(