aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Krysik <ptrkrysik@gmail.com>2017-08-24 15:35:42 +0200
committerPiotr Krysik <ptrkrysik@gmail.com>2017-08-24 15:35:42 +0200
commitbb961c17fabea1c3c796131e5c4317cdfb21c9fa (patch)
treee3ae9a4929d3da8be7fd5d7eedc7ba847030eadc /CMakeLists.txt
parent77868e4fa677c1b7964a4e948104de2b50d1570d (diff)
Added versioning borrowed fron GNU Radio to gr-gsm
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 20 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6e85472..13e1201 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,6 +36,17 @@ set(CMAKE_BUILD_TYPE ${CMAKE_BUILD_TYPE} CACHE STRING "")
list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/Modules)
########################################################################
+# Set version variables (
+########################################################################
+
+# Set the version information here
+set(VERSION_INFO_MAJOR_VERSION 1)
+set(VERSION_INFO_API_COMPAT 0)
+set(VERSION_INFO_MINOR_VERSION 0)
+set(VERSION_INFO_MAINT_VERSION git)
+include(GrVersion) #setup version info
+
+########################################################################
# Compiler specific setup
########################################################################
if(CMAKE_COMPILER_IS_GNUCXX AND NOT WIN32)
@@ -122,10 +133,9 @@ endif()
if(NOT LIBOSMOCORE_FOUND)
message(FATAL_ERROR "Libosmocore required to compile gr-gsm")
endif()
-message( dupa 2!!! )
-#if(NOT LIBOSMOCODEC_FOUND)
-# message(FATAL_ERROR "Libosmocodec required to compile gr-gsm")
-#endif()
+if(NOT LIBOSMOCODEC_FOUND)
+ message(FATAL_ERROR "Libosmocodec required to compile gr-gsm")
+endif()
#if(NOT LIBOSMOCODING_FOUND)
# message(FATAL_ERROR "Libosmocoding required to compile gr-gsm")
#endif()
@@ -218,3 +228,9 @@ set(CPACK_PACKAGE_MAINTAINER ptrkrysik@gmail.com)
set(CPACK_PACKAGE_DESCRIPTION "GSM functionality for Gnuradio")
set(CPACK_PACKAGE_CONTACT ptrkrysik@gmail.com)
include(CPack)
+
+########################################################################
+# Print summary
+########################################################################
+message(STATUS "Using install prefix: ${CMAKE_INSTALL_PREFIX}")
+message(STATUS "Building for version: ${VERSION} / ${LIBVER} / ${BUILD_DATE}")