aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2017-09-07 16:36:56 +0300
committerVadim Yanitskiy <axilirator@gmail.com>2017-12-31 12:20:59 +0100
commitc35ba8a725405f7712618871c56a3b7fb3933e2a (patch)
tree5150376f41c14f847cd0a09c31778cdf4af06ffc /src/Makefile.am
parentf8d91a07b45a618fd25c9d6edcf28218642044c9 (diff)
libosmogapk: use Osmocom logging framework
Since this change, the libosmogapk uses the Osmocom logging framework. By default, logging is disabled and could be enabled by the external applications calling the osmo_gapk_log_init() with a desired log target as an argument.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2c52ec1..060d435 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -76,6 +76,11 @@ libosmogapk_la_SOURCES += \
benchmark.c \
$(NULL)
+# Logging
+libosmogapk_la_SOURCES += \
+ logging.c \
+ $(NULL)
+
# libosmogapk representative application
bin_PROGRAMS = osmo-gapk