aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2013-02-11 11:34:58 +0100
committerHarald Welte <laforge@gnumonks.org>2013-02-11 11:38:23 +0100
commitce94d971e1223626c96ad32373ea4ff034233b50 (patch)
treebbe05c72550d305c50e07528547cb730f59bc4f7 /configure.ac
parentf7f0c91ca8c6cae331fa65db71f8c32502fad256 (diff)
gapk: Add support for RTP input/output streams
Instead of having only file-based I/O, this enables gapk to receive and send RTP streams, e.g. from live GSM network equipment like sysmoBTS/nanoBTS. Support is currently simplistic. On transmit, there is hard-coded codec type of full-rate GSM. On receive-side, we should auto-detect the format based on frame size and/or payload type, but we don't do that yet at all.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0b0968d..1208025 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,6 +49,7 @@ AC_PROG_LIBTOOL
# Checks for libraries.
# libosmocore (codec module)
+PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 0.3.2)
PKG_CHECK_MODULES(LIBOSMOCODEC, libosmocodec >= 0.1.25)
# opencore-amrnb for AMR and EFR decoding